Applies To
Scans initiated in Docker-based HawkScan implementations.
Issue
When running HawkScan against an FQDN configured in the host:
field in stackhawk.yml
, the scan terminates with the following error:
Error: Unable to access https://null.
Check if the web server is listening on the specified port.
At the same time, tests connections to the destination host via telnet
, nc
, or wget
may be succeeding, but only to the application's IP:PORT, not FQDN.
Cause
DNS issue in the Docker environment (the Docker host that HawkScan is running on can't resolve the configured FQDN in the host:
field.
Solution
Workaround:
Configure host:
with the IP and port of the associated application. For instance:
https://10.1.1.40:4000
(needs to be in URL format, so don't omit thehttp(s)://
)
Long-term Fix:
Resolve the DNS issues on the Docker host that HawkScan is running on such that it can resolve the target application.
Similar Issue
When encountering a similar error as above, except that it references https://IP:PORT
instead of https://null
, see 'Unable to access http://<host>:<port>' error when running Docker-based HawkScan.